Please Enable JavaScript!
Gon[ Enable JavaScript ]

반응형

안드로이드 개발을 위해서는 어떤 기기와 API 를 대상으로 할 것인지 정해야 합니다. 안드로이드는 지금까지 발표한 OS 버전에 따라 개발에 쓰인 API 버전이 틀립니다. 그리고 API 버전에 따라 개발에 사용할 수 있는 기능에 차이가 있습니다. 안드로이드에서 구현하고 싶은 기능이 있다면 API 버전과 지원 기기는 항상 확인해야겠죠. 오늘은 안드로이드 스튜디오에서 API 버전을 바꾸는 두 가지 방법을 알려 드리겠습니다.

 

 

첫 번째 방법은 Module build.gradle 정보를 수정하는 것입니다. Gradle Scripts 에서 build.gradlle(Module:app) 을 열어 보세요. 내용에서 defaultConfig 를 찾습니다. 그리고 안드로이드 앱이 실행될 수 있는 최소 버전인 minSdkVersion 과 앱의 타겟 API 버전 targetSdkVersion 을 변경합니다. 만약 targetSdkVersion 선언되어 있지 않다면 minSdkVersion 버전으로 적용합니다.

안드로이드 스튜디오 Android Studio API 레벨 바꾸는 두 가지 방법

 

두 번째는 Module Settings 설정 화면에서 변경하는 것입니다. 프로젝트를 선택하고 오른쪽 마우스를 누릅니다. 그리고 Open Module Settings 메뉴를 선택합니다. 또는 단축키 F12 를 눌러서 바로 실행할 수 있습니다

안드로이드 스튜디오 Android Studio API 레벨 바꾸는 두 가지 방법

 

※ 아래는 참고하면 좋을 만한 글들의 링크를 모아둔 것입니다.
안드로이드 스튜디오 개발 유용한 단축키, 함수, 클래스, 파일, 라인 이동
안드로이드 스튜디오 설치해서 사용하는 방법
안드로이드 스튜디오 이클립스 단축키 세팅으로 변경하는 방법
안드로이드 스튜디오 중요 소스 위치에 북마크 이용하기
드로이드 스튜디오 간단하게 외부 라이브러리 추가하는 방법



 

 

 

Module Settings 화면에서 Flavors 탭으로 이동합니다. 그리고 Min Sdk Version Target Sdk Version 을 수정합니다

안드로이드 스튜디오 Android Studio API 레벨 바꾸는 두 가지 방법

 

그림처럼 콤보 박스에는 선택 가능한 API 와 안드로이드 버전 목록이 나타납니다. 이렇게 선택한 값들은 build.gradle 에 적용됩니다

안드로이드 스튜디오 Android Studio API 레벨 바꾸는 두 가지 방법

 

만약 목록에 API 버전이 없다면 SDK Manager 에서 다운받아야 합니다

안드로이드 스튜디오 Android Studio API 레벨 바꾸는 두 가지 방법

※ 아래는 참고하면 좋을 만한 글들의 링크를 모아둔 것입니다.
안드로이드 스튜디오 개발 유용한 단축키, 함수, 클래스, 파일, 라인 이동
안드로이드 스튜디오 설치해서 사용하는 방법
안드로이드 스튜디오 이클립스 단축키 세팅으로 변경하는 방법
안드로이드 스튜디오 중요 소스 위치에 북마크 이용하기
드로이드 스튜디오 간단하게 외부 라이브러리 추가하는 방법
반응형
Posted by 녹두장군

댓글을 달아 주세요